Subscription Service is fine again. We notice occasional issues with EC2 instances in us-east-1 when being restarted, being stuck in stopping state. We're actively working on recovering those machines as fast as possible.
Posted Oct 20, 2025 - 12:24 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 12:22 UTC
Update
We see continous recovery on the subscription service, reducing severity from major outage to degraded performance and continue monitoring.
Listing existing subscriptions/instances on app.my-prtg.com might be still impaired, same goes for booking new subscriptions or starting PRTG Hosted Monitor trials.
Recovery is currently ongoing, we monitor the situation and post an update.
Posted Oct 20, 2025 - 09:39 UTC
Investigating
We are currently seeing elevated error rates impacting several services. Services related to booking/managing subscriptions are impaired as well. Existing subscriptions are currently also not showing.
Posted Oct 20, 2025 - 08:02 UTC
This incident affected: PRTG Instances (AWS EC2 Instances (us-east-1 - United States - Northern-Virginia)).